summaryrefslogtreecommitdiff
path: root/build-openwrt-dev.sh
diff options
context:
space:
mode:
authorLudovic Pouzenc <ludovic@pouzenc.fr>2017-06-05 13:26:39 +0200
committerLudovic Pouzenc <ludovic@pouzenc.fr>2017-06-05 13:26:39 +0200
commit5f34b312d3bf305a0f1d5b388270de0a30ae3146 (patch)
treedd445c6aa5ff6a62a12f42ef11bbd0ed01722528 /build-openwrt-dev.sh
parent6074c1f152347eaea478111a56fe1746c53c5dbb (diff)
downloadchd_openwrt-5f34b312d3bf305a0f1d5b388270de0a30ae3146.zip
chd_openwrt-5f34b312d3bf305a0f1d5b388270de0a30ae3146.tar.gz
chd_openwrt-5f34b312d3bf305a0f1d5b388270de0a30ae3146.tar.bz2
Hotfix for 9a1fd3e buildroot that refers to unavailable logd package
Was applied by hand on dev. Now automated on both.
Diffstat (limited to 'build-openwrt-dev.sh')
-rwxr-xr-xbuild-openwrt-dev.sh14
1 files changed, 14 insertions, 0 deletions
diff --git a/build-openwrt-dev.sh b/build-openwrt-dev.sh
index 734f59e..5977122 100755
--- a/build-openwrt-dev.sh
+++ b/build-openwrt-dev.sh
@@ -99,6 +99,20 @@ if [ ! -f "$BUILD_DIR/Makefile" ]; then
wget -O "$CACHE_DIR/$ORIG_TARBALL" "$ORIG_URL"
fi
tar -x -C "$BUILD_DIR/" --strip-components=1 -f "$CACHE_DIR/$ORIG_TARBALL"
+ # Hotfix about "logd" package not availble on chaos-calmer
+ patch -d "$BUILD_DIR/" -p1 <<"EOT"
+--- a/include/target.mk 2017-04-01 22:00:23.000000000 +0200
++++ b/include/target.mk 2017-04-03 20:01:23.620028730 +0200
+@@ -12,7 +12,7 @@
+ DEVICE_TYPE?=router
+
+ # Default packages - the really basic set
+-DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg netifd fstools logd
++DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg netifd fstools
+ # For nas targets
+ DEFAULT_PACKAGES.nas:=block-mount fdisk lsblk mdadm
+ # For router targets
+EOT
fi
cd "$BUILD_DIR/" || exit 5