summaryrefslogtreecommitdiff
path: root/package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch
diff options
context:
space:
mode:
authorLudovic Pouzenc <ludovic@pouzenc.fr>2018-09-16 19:55:45 +0200
committerLudovic Pouzenc <ludovic@pouzenc.fr>2018-09-16 19:55:45 +0200
commitc0ce88c586a467665b35d93c2f6962cac8e8dc27 (patch)
treedf24b1ae76338fa83f45c14f8518720f0266705d /package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch
parentffb3f790a5075e5c294420e8348dfe6c429ac921 (diff)
downloadmtk-20170518-c0ce88c586a467665b35d93c2f6962cac8e8dc27.zip
mtk-20170518-c0ce88c586a467665b35d93c2f6962cac8e8dc27.tar.gz
mtk-20170518-c0ce88c586a467665b35d93c2f6962cac8e8dc27.tar.bz2
mt7xxx proprietary Wifi drivers integration + mac80211 weird changes
Diffstat (limited to 'package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch')
-rw-r--r--package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch b/package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch
new file mode 100644
index 0000000..3429f57
--- /dev/null
+++ b/package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch
@@ -0,0 +1,20 @@
+Index: mt7628sta-4.0.1.4/mt_wifi_sta/Makefile
+===================================================================
+--- mt7628sta-4.0.1.4.orig/mt_wifi_sta/Makefile
++++ mt7628sta-4.0.1.4/mt_wifi_sta/Makefile
+@@ -1,10 +1,10 @@
+-EXTRA_CFLAGS = -Idrivers/net/wireless/mt_wifi/include \
+- -Idrivers/net/wireless/mt_wifi/embedded/include \
+- -Idrivers/net/wireless/mt_wifi/ate/include
++EXTRA_CFLAGS = -I$(src)/../mt_wifi/include \
++ -I$(src)/../mt_wifi/embedded/include \
++ -I$(src)/../mt_wifi/ate/include
+
+-DRV_NAME = mt_wifi
++DRV_NAME = mt7628sta
+ SRC_DIR = ../mt_wifi/embedded
+-obj-$(CONFIG_MT_STA_SUPPORT) += $(DRV_NAME).o
++obj-m += $(DRV_NAME).o
+
+ ########################################################
+ # Common files