summaryrefslogtreecommitdiff
path: root/package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch')
-rw-r--r--package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch b/package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch
new file mode 100644
index 0000000..3429f57
--- /dev/null
+++ b/package/ramips/drivers/mt7628sta/patches/001-openwrt-build.patch
@@ -0,0 +1,20 @@
+Index: mt7628sta-4.0.1.4/mt_wifi_sta/Makefile
+===================================================================
+--- mt7628sta-4.0.1.4.orig/mt_wifi_sta/Makefile
++++ mt7628sta-4.0.1.4/mt_wifi_sta/Makefile
+@@ -1,10 +1,10 @@
+-EXTRA_CFLAGS = -Idrivers/net/wireless/mt_wifi/include \
+- -Idrivers/net/wireless/mt_wifi/embedded/include \
+- -Idrivers/net/wireless/mt_wifi/ate/include
++EXTRA_CFLAGS = -I$(src)/../mt_wifi/include \
++ -I$(src)/../mt_wifi/embedded/include \
++ -I$(src)/../mt_wifi/ate/include
+
+-DRV_NAME = mt_wifi
++DRV_NAME = mt7628sta
+ SRC_DIR = ../mt_wifi/embedded
+-obj-$(CONFIG_MT_STA_SUPPORT) += $(DRV_NAME).o
++obj-m += $(DRV_NAME).o
+
+ ########################################################
+ # Common files